RSS feeds kører igen

User avatar
jonaz.dk
Site Admin
Posts: 2297
Joined: 04 Mar 2008, 22:24
Location: DK
Contact:

RSS feeds kører igen

Unread post by jonaz.dk » 16 Mar 2008, 00:09

hepsa.. som kom RSS feeds op at køre igen.
der er tale om noget beta snask.. så muligvis kan der dukke uregelmæssigheder om.
Alle gamle feeds fra det tidligere forum peger på det nye feed.. hvor ALT er med.

Det nye RSS feed kører på forum ID hvis man gerne vil følge et specifikt forum..
Og ikke med særskilte php filer som var tilfældet i den gamle implementation.

Der er desuden mulighed for at sammensætte forskellige klynger af feeds. Sæt komma mellem hver ID i feedet. (fx. ?fid=5,16,2,8)

De nye feeds ser ud som følgende

Alle forums
http://spiludvikling.dk/rss.php

Info og nyheder
http://spiludvikling.dk/rss.php?fid=5

Arrangementer og tradeshows
http://spiludvikling.dk/rss.php?fid=16

Artikler og Links til spilbranchen
http://spiludvikling.dk/rss.php?fid=2

Jobs
http://spiludvikling.dk/rss.php?fid=8

Til og fra Spiludvikling.dk
http://spiludvikling.dk/rss.php?fid=9

Showcase - Work in progress og final
http://spiludvikling.dk/rss.php?fid=10

Offtopic
http://spiludvikling.dk/rss.php?fid=12

Branchen og uddannelse
http://spiludvikling.dk/rss.php?fid=11

Kode
http://spiludvikling.dk/rss.php?fid=13

Software og udvikling
http://spiludvikling.dk/rss.php?fid=15

IGDA
http://spiludvikling.dk/rss.php?fid=17

davidhelgason
Level 8 - Summoner
Posts: 86
Joined: 12 Mar 2008, 13:49

Re: RSS feeds kører igen

Unread post by davidhelgason » 16 Mar 2008, 23:44

Det er ærgerligt at du er blvet kastet ud i serveropsætning og PHP stuff, når du nu bare ville diskutere spilbranchen med dine venner. Tak for at blive ved med at køre det her forum!

Og så bare én ting som jeg faldt over: links i feeded bliver genereret med "sid=XXXXXXXXXXXXXXXXXXXXXXXX" på URLen, hvor XXXXXXXXXXXXXXXXXXXXXXXX er tilfældigt generet hver gang jeg reloader feedet, og det får min RSS reader til at tro at alle posts er ændret så "læst" markeringen går væk. Det er sikkert lidt forkselligt mellem RSS klienter hvordan det virker, men ja... det er måske noget man kan konfigurere sig ud af i PHPBB.

d.

User avatar
jonaz.dk
Site Admin
Posts: 2297
Joined: 04 Mar 2008, 22:24
Location: DK
Contact:

Re: RSS feeds kører igen

Unread post by jonaz.dk » 17 Mar 2008, 08:05

@David.
Jaja.. Jeg gør hvad jeg kan.. trods en masse ikke færdigtudviklede mods og måske ikke med de voldsomme tekniske kompetencer. ;)
Nå men det er godt jeg får fingrene ned under motorhjelmen. Det kan man kun blive klogere af.

Og desuden er der ingen grund til at undervurdere spiludvikling.dk's indflydelse på branchen som rækker langt ud over "Jonas hyggesnakker med sine venner på nettet" ;)

uden din specifikke RSS reader er det svært for mig at konfigurere sig ud af.
i tråden for selve det ufærdige RSS mod jeg benytter ligger der en jungle af 1000 forskellige små fixes (og unfixes).
muligt jeg kaster mig over det igen når der bliver tid.

hos mig virker Sharpreader perfekt.. http://reader.google.com (som er guld, by the way hvis man har sin daglige gang på mange forskellige maskiner) er den eneste fejl at navnet på feedet ikke kommer med når man adder det.

User avatar
Razu
Level 1 - Speck of dust
Posts: 15
Joined: 15 Mar 2008, 14:14
Location: Copenhagen, Denmark
Contact:

Re: RSS feeds kører igen

Unread post by Razu » 17 Mar 2008, 10:14

Ja - tak for et super site :)

Jeg har samme problem med min RSS som David skriver. Jeg bruger bare den som er indbygget i Internet Explorer 7 :P

Keep up the good work :geek:
Mvh,
Rasmus Boserup

User avatar
jonaz.dk
Site Admin
Posts: 2297
Joined: 04 Mar 2008, 22:24
Location: DK
Contact:

Re: RSS feeds kører igen

Unread post by jonaz.dk » 17 Mar 2008, 22:41

FYI: (også tilføjet i første post)
Det nye RSS feed kører på forum ID hvis man gerne vil følge et specifikt forum..
Og ikke med særskilte php filer som var tilfældet i den gamle implementation.

De specifikke feeds ser ud som følgende

Alle forums
http://spiludvikling.dk/rss.php

Info og nyheder
http://spiludvikling.dk/rss.php?fid=5

Arrangementer og tradeshows
http://spiludvikling.dk/rss.php?fid=16

Artikler og Links til spilbranchen
http://spiludvikling.dk/rss.php?fid=2

Jobs
http://spiludvikling.dk/rss.php?fid=8

Til og fra Spiludvikling.dk
http://spiludvikling.dk/rss.php?fid=9

Showcase - Work in progress og final
http://spiludvikling.dk/rss.php?fid=10

Offtopic
http://spiludvikling.dk/rss.php?fid=12

Branchen og uddannelse
http://spiludvikling.dk/rss.php?fid=11

Kode
http://spiludvikling.dk/rss.php?fid=13

Software og udvikling
http://spiludvikling.dk/rss.php?fid=15

IGDA
http://spiludvikling.dk/rss.php?fid=17

User avatar
Razu
Level 1 - Speck of dust
Posts: 15
Joined: 15 Mar 2008, 14:14
Location: Copenhagen, Denmark
Contact:

Re: RSS feeds kører igen

Unread post by Razu » 06 Apr 2008, 01:38

Jeg ved ikke om jeg er den eneste, men jeg kan ikke få http://www.spiludvikling.dk/rss.php til at virke? Hverken i IE feed readeren eller i FeedDemon :( De andre virker dog.

Det ovenfor nævnte feed giver mig en "Feed normalization error" - hvis det kan hjælpe?

User avatar
jonaz.dk
Site Admin
Posts: 2297
Joined: 04 Mar 2008, 22:24
Location: DK
Contact:

Re: RSS feeds kører igen

Unread post by jonaz.dk » 06 Apr 2008, 09:29

jeps.. I know.
den har virket i rss.php på et tidspunkt. (eller den virker på reader.google.com) men har problemer andre steder.
jeg ved faktisk ikke hvorfor den er gået kold.
det må være et eller andet i formateringen.. data'en kommer med.
hvis jeg laver View page source er der fin XML data. som dog ikke bliver vist i browseren.

jeg har prøvet at installere andre versioner af samme mod.. men de går fuldstændigt kolde.
jeg krydser fingre for at der snart kommer en release candidate så vi slipper for det her beta helvede.

User avatar
jonaz.dk
Site Admin
Posts: 2297
Joined: 04 Mar 2008, 22:24
Location: DK
Contact:

Re: RSS feeds kører igen

Unread post by jonaz.dk » 06 Apr 2008, 10:32

så... sgu!
nu fandt jeg problemet :)

det var den post i dette forum hvor jeg smed RSS php+xml filerne ind som code. der må have været nogle tegn i feedet som det ikke havde det så godt med.

derfor at alle andre specifikke forums virkede.

men det burde virke nu... fingers crossed.
http://spiludvikling.dk/rss.php

dasapfe
Level 1 - Speck of dust
Posts: 17
Joined: 08 Mar 2008, 16:10

Re: RSS feeds kører igen

Unread post by dasapfe » 06 Apr 2008, 17:08

Jeg ville lige prøve den, men jeg får en "Feed-kodefejl" i IE7. Her er hvad den brokkede sige over (ironisk nok er det åbenbart et af mine egne indlæg):
Der blev fundet et ugyldigt tegn i tekstindholdet.
Linje: 334 Tegn: 951

<description><![CDATA[Du sagde i din første post at problemet var at Derived nedarvede fra Base 2 gange, men i det kode du har postet nedarver du stadigvæk fra Base 2 gange (explicit, og gennem A) ... <img src="http://spiludvikling.dk/images/smilies/ ... estion.gif" alt=":?:" title="Question" /> <br /><br />Mente du:<br /><div class="codewrapper"><div class="codetitle"><b>Code:</b></div><div class="codecontent">class Derived: public A, public MyBase<br />{<br />}</div></div><br /><br /><div class="quotewrapper"><div class="quotetitle">tandersen wrote:</div><div class="quotecontent">Compileren har dog ikke noget problem med det</div></div><br />Det har den faktisk, fordi den ikke kan finde ud af hvilken af de 2 funktioner den skal kalde. Forestil (for simplicitetens skyld) at 'Base' indeholdt en 'int foo' :<br /><div class="codewrapper"><div class="codetitle"><b>Code:</b></div><div class="codecontent">Derived der;<br />der.foo = 0;

User avatar
Razu
Level 1 - Speck of dust
Posts: 15
Joined: 15 Mar 2008, 14:14
Location: Copenhagen, Denmark
Contact:

Re: RSS feeds kører igen

Unread post by Razu » 06 Apr 2008, 17:30

Jeg får stadig samme fejl i IE 7 - men det virker i FeedDemon nu.

Eneste problem jeg så har er at den konsekvent, hver gang der skrives et nyt indlæg, noterer som at alle indlæg er nye :?

Derudover virker det som om at alle danske bogstaver får den til at gå amok med en masse underlige tegn i stedet for ÆØÅ.
Mvh,
Rasmus Boserup

User avatar
jonaz.dk
Site Admin
Posts: 2297
Joined: 04 Mar 2008, 22:24
Location: DK
Contact:

Re: RSS feeds kører igen

Unread post by jonaz.dk » 06 Apr 2008, 17:56

ahh.. doh.. fik selvfølgelig ikke lige testet i IE.. FireFox virkede glimragene. hvad er det også for en skrammel browser i bruger. stram op! ;)

nå.. det er klart Code bracketen der skaber de største problemer.. jeg redigerede så småt i div. posts. og fik fikset det. men ja.. det sutter. :x

angående posts der bliver genfornyede og skummel fortolkning af ÆØÅ så må jeg desværre (i nuværende stund) henvise til andre RSS readers.
indtil der forhåbenligt kommer en ordenlig udgave af det mod jeg bruger på gaden.

jeg har rodet lidt med ISO formatet på feedet og det blev det bare meget værre af.

User avatar
Razu
Level 1 - Speck of dust
Posts: 15
Joined: 15 Mar 2008, 14:14
Location: Copenhagen, Denmark
Contact:

Re: RSS feeds kører igen

Unread post by Razu » 06 Apr 2008, 20:02

Så nu virker det mindsandten :D

Både i IE 7 og jeg kan se danske bogstaver i FeedDemon..... good work!

Rart at kunne følge med her inde igen :lol:
Mvh,
Rasmus Boserup

fehaar
Level 13 - Portal opener
Posts: 137
Joined: 13 Mar 2008, 23:59

Re: RSS feeds kører igen

Unread post by fehaar » 07 Apr 2008, 22:44

Det er SÅ rart at RSS er oppe igen. Good work Jonas. Var lidt miffed over at nå op på 400+ posts i min reader på et par dage. Men når man får fire versioner af alle posts herinde løber det jo hurtigt op. :P

gjoel
Level 3 - Infant
Posts: 34
Joined: 17 Mar 2008, 13:15

Re: RSS feeds kører igen

Unread post by gjoel » 01 Aug 2008, 15:43

...og nu er de døde igen, og har været det i et par uger, right?

User avatar
jonaz.dk
Site Admin
Posts: 2297
Joined: 04 Mar 2008, 22:24
Location: DK
Contact:

Re: RSS feeds kører igen

Unread post by jonaz.dk » 03 Aug 2008, 21:11

har smidt Simple Syndication 1.1.1g op af som efter signede skulle være den nyeste der virker.
krydser fingre for at de har fået mere styr på det.
men har samtidigt ikke for megen tiltro til deres kodeevner. :)
nu må vi se.

Post Reply